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Quantitative and Qualitative Chemical Analysis of Minerals

The primary tool for determining the compositions of minerals today is the electron microprobe.
The electron microprobe uses a finely focused electron beam to excite the emission of x-rays from
a small area of a polished mineral surface. The instrument is capable of making in situ composi-
tion measurements of minerals in rocks. With the probe, you can measure the composition (and
determine the identity) of grains too small to identify under the microscope. You can measure the
compositions of different parts of a single grain to determine whether the grain is homogeneous.
You can measure the compositions and identify the grains throughout a thin section of a rock to
determine the rock’s mode (the volume percent of a mineral in the rock) and its bulk composition.
You can measure the emitted x-ray intensity over an area in the rock to see the texture and growth
history of the minerals. The ability to make all these measurements makes the electron microprobe
one of the most important tools in the mineralogist’s toolkit for determining the origin of rocks
and minerals.

The electron microprobe is the same instrument as the scanning electron microscope, with some
changes to the sample stage to allow for analysis of standards and with the addition of one or more
spectrometers to analyze the intensity of the characteristic x-rays emitted by the sample. The
electron microprobe (EMP) and the scanning electron microscope (SEM) are really nothing more
than an x-ray tube, which we’ve already talked about in the previous labs. A filament, usually
tungsten, is heated by a current and emits electrons. The electrons are accelerated toward a target,
which in this case is a rock or mineral sample instead of copper. The electrons strike the sample and
emit a continuum of x-rays (bremstrahlen) and characteristic x-rays. The characteristic spectrum
is what we are interested in. If we can determine the wavelengths of the characteristic lines, we then
know the elements present in the sample. If we measure the intensities of the lines, we then know
the abundance of the elements in the sample. Two parts make the EMP different from an ordinary
x-ray tube: the electrons are focused to a fine beam by electromagnets, and a spectrometer and
counter are attached to measure the wavelengths and intensities of the emitted x-rays. A diagram
of an electron microprobe is shown in Figure 1.

The probe routinely can be focused to a diameter as small as 1 µm (SEM beams can be much
finer). Under common operating conditions, that diameter probe is as fine as possible because the
electrons striking the sample excite x-ray emission from a sample volume that doesn’t decrease
with smaller probe sizes.

In this lab, you will explore three uses of electron microprobe analysis: quantitative analysis
(first and foremost!), modal and textural analysis, and compositional zoning in a single mineral
grain. All are examples of data from my own studies of metamorphic rocks.

1. Quantitative analysis generally requires not only the unknown sample, but also a set of
standards to compare with the unknown-sample’s x-ray intensities. The concept is that the
intensity of an x-ray line is directly proportional to the concentration of the element in the
sample. In practice this isn’t true because x-rays emitted by one element can be absorbed
by another element, causing it to fluoresce. The result is a reduced intensity. Also, x-rays
emitted by another element can induce fluorescence in the element of interest and result
in an enhanced x-ray intensity. So, in the process of quantitative analysis, raw intensities
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Figure 1: Schematic of an electron microprobe fitted with both a wavelength-dispersive and an
energy-dispersive spectrometer.

are corrected for absorption and fluorescence to obtain the real concentration. To do this
correction, you have to know the concentrations of the other elements in the sample, but,
of course, those are unknown, too. The procedure works by taking as a first approximation
the uncorrected concentrations, applying the corrections, and then redoing the calculation.
Eventually, the iterative procedure converges on the actual concentrations.
There are a few methods available to do the corrections. The earliest is an empirical correction
scheme developed by Bence and Albee. Here, several standards are analyzed to measure the
relation between concentration and intensity. From those measurements, a set of correction
factors were obtained, and those are what are used in the analysis of the unknown mineral.
Here’s the idea. If C0 is the concentration of an element in a standard sample, then the
uncorrected apparent concentration C ′ is given by

C ′ = C0

(
I

I0

)
where I is the x-ray intensity of the unknown sample and I0 is the intensity in the standard.
The effect of an element B on the concentration of element A is approximated by the relation

C ′A = αACA
αACA + αBCB

In a binary system, CB = 1− CA and the expression can be rewritten as

CA
C ′A

= αAB + (1− αAB)CA
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Figure 2: Apparent concentration of element A (C ′A) versus true concentration (CA)in a binary
A–B alloy: (a) α > 1, (b) α = 1, (c) α < 1.

where αAB = αB/αA. The relation between the apparent and true concentration of A is
shown in Figure 2. The αAB is the effect of a small amount of A in B.
In this exercise, apply the standard data in Table ?? to the intensities of the unknown sample
in Table ?? to obtain the apparent concentrations (C ′). You will need to take the counts for
the element and subtract the background counts—the background arises from the continuous
spectrum and needs to be removed. Then calculate the ratio of intensities I/I0 and multiply
by the weight percent of the oxide in the standard to get the apparent concentration. Finally
compare the apparent concentrations with the corrected values to see the effects of absorption
and fluorescence.

2. If you place a polished thin section on the EMP stage, then you can automatically count
specific elements on a spot for a given time and then move the stage and repeat. The result
is an array of points for which you have x-ray counts on the elements of interest. With
the aid of visualization programs, you can convert the arrays of counts to images that allow
you to see the mineral textures and even identities. You get spatial information about the
constitution of your sample. This procedure is illustrated with a sample of dolomite that has
been partially reacted to a mixture of calcite and periclase. You will use a particular program
called Transform, although other programs are available to do the job, too.
There are three files in the folder LM 9 images: LM9 BSE.raw, LM9 Mg.raw, and LM9 Ca.raw.
These files contain back-scattered electron (BSE) intensity data and intensity data for Mg
and Ca Kα. The intensity of BSE, resulting from the electrons bouncing off the surface,
is directly related to the average atomic number of the sample. It gives reasonably clear
micrograph showing mineral texture. The Mg and Ca x-ray images show qualitatively the
mineral compositions, allowing you to distinguish calcite from dolomite. The data are in a raw
format, which means that the values are written in binary format and have to be converted
before they can be used.
First launch the Transform program (it is a Mac classic application). Second, choose Open
and select the file to open. You will be asked about the format of the file. The three files
have a 512× 512 pixel array. The data in the BSE file are unsigned 8-bit integers, and there
is a 1118-byte header (information preceding the actual data). The x-ray data are unsigned
16-bit integers with a 1117-byte header. With those values, you should be able to open the
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files and generate an image (command-G). The images are eight bits deep, and you can assign
colors to the values in the Color tables menu.
What we want to do is to identify calcite, dolomite, periclase, and so on. This becomes a
game of determining possible ranges in Mg and Ca counts for each and then masking the
points that don’t fit the range. For example, we’ll find all the points that have Mg between
50 and 109 counts (I have predetermined this for you) and Ca between 70 and 106 counts.
Those points are dolomite. So we’ll create a 512 × 512 array with a value of 1 if the point
passes the criteria or 0 if it fails. The total of the array is the number of dolomite points.
The ratio with the total number of points, 262144− points not on the sample, gives you the
fraction that is dolomite.
To do this calculation, open a notebook in one of the files (Numbers -> See notebook,
command N). Type the following in the notebook (there are function pop-ups at the bottom
of the notebook window).

Calcite=GEmask(Ca_Ka,125)

Dolomite=GEmask(Mg_Ka,50)*LEmask(Mg_Ka,109)*GEmask(Ca_Ka,70)*LEmask(Ca_Ka,106)

Nesquehonite=GEmask(Mg_Ka,60)*LEmask(Mg_Ka,160)*LEmask(Ca_Ka,10)

Mag_phase=GEmask(Mg_Ka,160)*LEmask(Ca_Ka,50)

micrograph=64*GEmask(Ca_Ka,107)+128*(GEmask(Mg_Ka,50)*LEmask(Mg_Ka,109)
*GEmask(Ca_Ka,70)*LEmask(Ca_Ka,106))+192*GEmask(Mg_Ka,60)*LEmask(Mg_Ka,160)
*LEmask(Ca_Ka,10)+255*GEmask(Mg_Ka,160)+32*GEmask(Mg_Ka,10)*GEmask(Ca_Ka,10)

To execute the commands, place the cursor on one of the lines and choose Calculate from
notes (command R) from the Numbers menu. Do this for each line. You will get a new
window for each with the arrays of 1s and 0s. You can generate an image for each to see the
distribution of the grains. To get the totals for each mineral, type print sum(dolomite)
and command R to execute it.
The last line, defining micrograph, creates an image with a different color for each mineral,
so you can see the whole sample with each mineral identified. You can play with the color
tables to get it the way you like. Here is one example that I created (Fig. 3).

3. Visualization is also useful to assess compositional variation within single mineral grains.
Garnet, for example, is commonly heterogeneous, particularly in rocks that formed in medium-
temeprature metamorphic environments. We will look at an example from the Blue Ridge of
North Carolina.
The analytical procedure is identical to that in the previous exercise. The sample is placed
on a stage in the EMP, and the stage is moved to create a grid of points where x-ray data
are collected. There is a folder on the file server that contains garnet x-ray data (Garnet
images). In these files, the data are in a text format with each row of numbers separated by
a return and numbers within the row separated by tabs. There are still 512× 512 data, but
the files are a lot larger because the numbers are represented in text (ASCII) format.
We will open the files and create images with the program Image J, a public-domain Java
program developed by the National Institutes of Health. The version on the file server is for
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Figure 3: Sample LM 9 with dolomite colored medium blue, calcite is dark blue, nesquehonite is
light blue, and periclase is pink.

the Macintosh, but versions for Linux and Windows are available on the NIH Image J web
site.
Launch Image J and choose Import -> Text image from the File menu. Select the file SS
Gar Ca.txt. Also import the files for Fe, Mg, and Mn. These are elements that commonly
range in composition in garnet grains. The files will be opened as 32-bit gray-scale images.
You should be able to see the variation in gray scale in the large garnet grain that nearly fills
the field of view. The Ca image is particularly striking. We want to create an image that
combines the Ca, Fe, and Mg data to create a color visualization of the zoning.
To do this, first change the open gray-scale images to 8-bit: bring each image to the front and,
in turn, change the Image->Type->8 bit from the menu bar. Now create a new image from
the File menu and select RGB as the type and 512× 512 as the dimensions in the window that
opens. You can also name the file there. Now with the new blank image at the front, change
the Image -> Type to RGB stack. This lets you place an 8-bit image in each of the red,
green, and blue channels. I placed the Ca image in the red channel by first bringing the Ca
image to the front, selecting all (command A), copying (command C), and pasting (command V)
into the new window. Then I changed to the green channel from the scroll bar at the bottom
of the new window, I copied the Fe image, and then I pasted it into the green channel. I
repeated this for the Mg image, pasting it into the blue channel. Finally I switched the image
type back to RGB and got the image in Figure 4.
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Figure 4: A sample of garnet from Cullowhee, North Carolina, showing distinctly in red the Ca-rich
regions and, more subtly, the variation in Fe and Mg.
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